Outage

Incident Report for Document Crunch

Resolved

This incident has been resolved and is being monitored.
Posted Apr 10, 2026 - 04:02 UTC

Investigating

We are currently investigating this issue.
Posted Apr 10, 2026 - 04:01 UTC